@MakotoSato_DBREPostgreSQLのCREATEDBはGRANTでは付けられない ―― MySQLとの権限モデルの違いと、SET ROLE利用時の落とし穴psql の \du には CREATEDB が見えているのに、CREATE DATABASE が権限エラーになる。原因は、ロール属性が current_user 基準で評価され、メンバーシップでは継承されないという PostgreSQL の仕様でした。September 24, 2026